f7201a9866fb306aada8280dbfac6879da2f8312
[gentoo.git] / dev-python / ipdbplugin / ipdbplugin-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Nose plugin to use iPdb instead of Pdb when tests fail"
10 HOMEPAGE="https://pypi.org/project/ipdbplugin/"
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-r3
14         SRC_URI=""
15         EGIT_REPO_URI="https://github.com/flavioamieiro/nose-ipdb.git"
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18         KEYWORDS="~amd64 ~x86"
19 fi
20
21 LICENSE="LGPL-2"
22 SLOT="0"
23 IUSE=""
24
25 RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]
26         dev-python/ipdb
27         dev-python/nose"
28 DEPEND="${RDEPEND}
29         dev-python/setuptools[${PYTHON_USEDEP}]"