sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / ipaddress / ipaddress-1.0.23.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
11 HOMEPAGE="https://github.com/phihag/ipaddress"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="PSF-2"
16 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE=""
18
19 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20
21 python_prepare_all() {
22         sed -i 's:unittest.main():unittest.main(verbosity=2):' \
23                 test_ipaddress.py || die
24
25         distutils-r1_python_prepare_all
26 }
27
28 python_test() {
29         "${PYTHON}" test_ipaddress.py || die
30 }