dev-python/click-default-group: keyworded 1.2.2 for ia64, bug #700918
[gentoo.git] / dev-python / httpstat / httpstat-1.2.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7
8 inherit distutils-r1
9
10 DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
11 HOMEPAGE="https://github.com/reorx/httpstat"
12 SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="net-misc/curl:*"
20
21 # Requires access to google.com and http2.akamai.com
22 RESTRICT="test"
23
24 PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
25
26 python_test() {
27         ./httpstat_test.sh || die
28 }