4b88281b5312ffa95b04bb66caeece9a45090d8f
[gentoo.git] / dev-python / healpy / healpy-1.11.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python wrapper for healpix"
11 HOMEPAGE="https://github.com/healpy"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/astropy[${PYTHON_USEDEP}]
21         dev-python/matplotlib[${PYTHON_USEDEP}]
22         dev-python/numpy[${PYTHON_USEDEP}]
23         sci-astronomy/healpix:=[cxx]
24         sci-libs/cfitsio:="
25 DEPEND="${RDEPEND}
26         dev-python/astropy-helpers[${PYTHON_USEDEP}]
27         dev-python/cython[${PYTHON_USEDEP}]
28         dev-python/pytest-runner[${PYTHON_USEDEP}]
29         dev-python/setuptools[${PYTHON_USEDEP}]
30         virtual/pkgconfig
31         test? (
32           dev-python/pytest[${PYTHON_USEDEP}]
33           dev-python/pytest-cython[${PYTHON_USEDEP}]
34         )
35 "
36
37 DOCS=( README.rst CHANGELOG.rst CITATION )
38
39 python_test() {
40         echo "backend: Agg" > matplotlibrc || die
41         MPLCONFIGDIR=. esetup.py test || die
42         rm matplotlibrc || die
43 }