048844f7e336a0961fcdbad1761292333d4e2e73
[gentoo.git] / dev-python / healpy / healpy-1.11.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python wrapper for healpix"
11 HOMEPAGE="https://github.com/healpy"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/astropy[${PYTHON_USEDEP}]
22         dev-python/matplotlib[${PYTHON_USEDEP}]
23         dev-python/numpy[${PYTHON_USEDEP}]
24         sci-astronomy/healpix:=[cxx]
25         sci-libs/cfitsio:="
26 DEPEND="${RDEPEND}
27         dev-python/astropy-helpers[${PYTHON_USEDEP}]
28         dev-python/cython[${PYTHON_USEDEP}]
29         dev-python/pytest-runner[${PYTHON_USEDEP}]
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         virtual/pkgconfig
32         test? (
33           dev-python/pytest[${PYTHON_USEDEP}]
34           dev-python/pytest-cython[${PYTHON_USEDEP}]
35         )
36 "
37
38 DOCS=( README.rst CHANGELOG.rst CITATION )
39
40 python_test() {
41         echo "backend: Agg" > matplotlibrc || die
42         MPLCONFIGDIR=. esetup.py test || die
43         rm matplotlibrc || die
44 }