sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-python / google-api-python-client / google-api-python-client-1.7.9.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Google API Client for Python"
11 HOMEPAGE="https://github.com/google/google-api-python-client"
12 SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
22         <dev-python/httplib2-1[${PYTHON_USEDEP}]
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
25         >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
26         >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
27         <dev-python/uritemplate-4[${PYTHON_USEDEP}]
28         >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
29         <dev-python/six-2[${PYTHON_USEDEP}]
30         "
31 DEPEND="${RDEPEND}
32         test? (
33                 dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
34                 dev-python/nose[${PYTHON_USEDEP}]
35                 dev-python/unittest2[${PYTHON_USEDEP}]
36         )"
37
38 python_prepare_all() {
39         export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
40         distutils-r1_python_prepare_all
41 }
42
43 python_test() {
44         nosetests --verbosity=3 || die
45 }