dev-python/mpi4py: x86 stable wrt bug #691966
[gentoo.git] / dev-python / google-api-python-client / google-api-python-client-1.7.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Google API Client for Python"
11 HOMEPAGE="https://github.com/google/google-api-python-client"
12 SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
17 IUSE="test"
18
19 RDEPEND="
20         >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
21         <dev-python/httplib2-1[${PYTHON_USEDEP}]
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
24         >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
25         >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
26         <dev-python/uritemplate-4[${PYTHON_USEDEP}]
27         >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
28         <dev-python/six-2[${PYTHON_USEDEP}]
29         "
30 DEPEND="${RDEPEND}
31         test? (
32                 dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
33                 dev-python/nose[${PYTHON_USEDEP}]
34                 dev-python/unittest2[${PYTHON_USEDEP}]
35         )"
36
37 python_prepare_all() {
38         export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
39         distutils-r1_python_prepare_all
40 }
41
42 python_test() {
43         nosetests --verbosity=3 || die
44 }