dd93f4241d3496fdfaf9622d16d734955127043e
[gentoo.git] / dev-python / genty / genty-1.3.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Allows you to run a test with multiple data sets"
11 HOMEPAGE="https://pypi.org/project/genty/ https://github.com/box/genty"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="Apache-2.0"
16 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/six[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( dev-python/mock[${PYTHON_USEDEP}] )
26 "
27
28 python_test() {
29         esetup.py test --verbose
30 }