830959047e598180ded3c5a4d0e837dab4de1b62
[gentoo.git] / dev-python / genshi / genshi-0.7.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 pypy )
6
7 inherit distutils-r1
8
9 MY_P="Genshi-${PV}"
10
11 DESCRIPTION="Python toolkit for stream-based generation of output for the web"
12 HOMEPAGE="http://genshi.edgewall.org/ https://pypi.org/project/Genshi/"
13 SRC_URI="http://ftp.edgewall.com/pub/genshi/${MY_P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
18 IUSE="doc examples"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND="${DEPEND}"
22
23 S="${WORKDIR}/${MY_P}"
24
25 python_test() {
26         esetup.py test
27 }
28
29 python_install_all() {
30         if use doc; then
31                 dodoc doc/*.txt
32                 dohtml -r doc/*
33         fi
34         if use examples; then
35                 insinto /usr/share/doc/${PF}
36                 doins -r examples
37         fi
38         distutils-r1_python_install_all
39 }