fc6e63a4c9d2baf5b0e4e71ab1ed71680d683bdf
[gentoo.git] / dev-python / future / future-0.16.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
11 HOMEPAGE="http://python-future.org/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ppc ~ppc64 ~sparc x86"
17 IUSE="test"
18
19 DEPEND="
20         test? (
21                 dev-python/pytest[${PYTHON_USEDEP}]
22         )
23 "
24
25 python_test() {
26         py.test -v || die "Tests failed under ${EPYTHON}"
27 }