Merge remote-tracking branch 'github/pr/108'
[gentoo.git] / dev-python / flask / flask-0.10.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
11 MY_PN="Flask"
12 MY_P="${MY_PN}-${PV}"
13 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
14 HOMEPAGE="https://github.com/mitsuhiko/flask/"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
19 IUSE="examples"
20
21 RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
22         >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
23         >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
26 DEPEND="${RDEPEND}"
27 # Usual; test phase
28 DISTUTILS_IN_SOURCE_BUILD=1
29
30 S="${WORKDIR}/${MY_P}"
31
32 PATCHES=( "${FILESDIR}"/${P}-is_package.patch
33                 "${FILESDIR}"/${P}-sort_json.patch
34                 "${FILESDIR}"/${P}-test_appcontext.patch )
35
36 python_test() {
37         "${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
38 }
39
40 python_install_all() {
41         use examples && local EXAMPLES=( examples/. )
42         distutils-r1_python_install_all
43 }