dev-python/cython: Drop some intermediate Versions, which seem to cause problems
[gentoo.git] / dev-python / expects / expects-0.8.0_rc1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
7
8 inherit distutils-r1 vcs-snapshot
9
10 MY_PV=${PV/_/}
11
12 DESCRIPTION="Expressive and extensible TDD/BDD assertion library for Python"
13 HOMEPAGE="https://github.com/jaimegildesagredo/expects"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="doc test"
20
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
24         test? ( dev-python/mamba[${PYTHON_USEDEP}] )
25 "
26 RDEPEND=""
27
28 python_compile_all() {
29         use doc && emake -C docs html
30 }
31
32 python_test() {
33         mamba || die "tests failed under ${EPYTHON}"
34 }
35
36 python_install_all() {
37         use doc && local HTML_DOCS=( docs/_build/html/. )
38
39         distutils-r1_python_install_all
40 }