sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-python / errorhandler / errorhandler-2.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Logging framework handler"
11 HOMEPAGE="https://pypi.org/project/errorhandler/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc test"
16 RESTRICT="!test? ( test )"
17
18 LICENSE="MIT"
19 SLOT="0"
20
21 RDEPEND=""
22 DEPEND="
23         dev-python/pkginfo[${PYTHON_USEDEP}]
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
26         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
27
28 PATCHES=(
29         "${FILESDIR}"/${PN}-2.0.1-no-intersphinx.patch
30 )
31
32 python_compile_all() {
33         use doc && emake -C docs html
34 }
35
36 python_test() {
37         nosetests -v || die "Tests fail with ${EPYTHON}"
38 }
39
40 python_install_all() {
41         use doc && local HTML_DOCS=( docs/_build/html/. )
42         distutils-r1_python_install_all
43 }