dev-python/rosdistro: initial import. ebuild by me.
[gentoo.git] / dev-python / enzyme / enzyme-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8 EGIT_REPO_URI="https://github.com/Diaoul/enzyme.git"
9
10 inherit distutils-r1 git-2
11
12 DESCRIPTION="Python video metadata parser"
13 HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.python.org/pypi/enzyme"
14 SRC_URI="test? ( http://downloads.sourceforge.net/project/matroska/test_files/matroska_test_w1_1.zip )"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="test"
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         test? (
24                 dev-python/requests[${PYTHON_USEDEP}]
25                 dev-python/pyyaml[${PYTHON_USEDEP}]
26         )
27         dev-python/setuptools[${PYTHON_USEDEP}]
28 "
29
30 python_prepare_all() {
31         if use test; then
32                 mkdir enzyme/tests/test_{parsers,mkv} || die
33                 ln -s "${WORKDIR}"/test* enzyme/tests/test_parsers/ || die
34                 ln -s "${WORKDIR}"/test* enzyme/tests/test_mkv/ || die
35         fi
36
37         distutils-r1_python_prepare_all
38 }
39
40 python_test() {
41         esetup.py test
42 }