media-fonts/font-misc-misc: dropped ~x86-interix
[gentoo.git] / dev-python / enzyme / enzyme-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
8 PYTHON_REQ_USE='xml(+)'
9
10 inherit distutils-r1 git-r3
11
12 DESCRIPTION="Python video metadata parser"
13 HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.python.org/pypi/enzyme"
14 EGIT_REPO_URI=( {https,git}://github.com/Diaoul/${PN}.git )
15 SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )"
16
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="test"
21
22 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}
24         test? (
25                 app-arch/unzip
26                 dev-python/pyyaml[${PYTHON_USEDEP}]
27                 dev-python/requests[${PYTHON_USEDEP}]
28         )
29 "
30
31 src_unpack() {
32         default_src_unpack
33         git-r3_src_unpack
34 }
35
36 python_prepare_all() {
37         if use test; then
38                 mkdir enzyme/tests/test_{mkv,parsers} || die
39                 ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_mkv/ || die
40                 ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_parsers/ || die
41         fi
42
43         distutils-r1_python_prepare_all
44 }
45
46 python_test() {
47         esetup.py test
48 }