Use https by default
[gentoo.git] / dev-python / envisage / envisage-4.4.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # py2.6 fails testsuite horribly
8 PYTHON_COMPAT=python2_7
9
10 inherit distutils-r1 virtualx
11
12 DESCRIPTION="Enthought Tool Suite: Extensible application framework"
13 HOMEPAGE="http://code.enthought.com/projects/envisage"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
19 IUSE="test"
20
21 RDEPEND=">=dev-python/traits-4[${PYTHON_USEDEP}]"
22 DEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 >=dev-python/traits-4[${PYTHON_USEDEP}]
26                 dev-python/apptools[${PYTHON_USEDEP}]
27                 media-fonts/font-cursor-misc
28                 media-fonts/font-misc-misc
29         )"
30
31 # tests are buggy version after version
32 RESTRICT=test
33
34 python_test() {
35         VIRTUALX_COMMAND="nosetests" virtualmake
36 }