dev-python/docutils-glep: ppc64 stable wrt bug #687050
[gentoo.git] / dev-python / docutils-glep / docutils-glep-1.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
7
8 inherit distutils-r1
9
10 MY_PN=${PN/-/_}
11 MY_P=${MY_PN}-${PV}
12 DESCRIPTION="Gentoo GLEP support for docutils"
13 HOMEPAGE="https://github.com/gentoo/docutils-glep/"
14 SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="public-domain"
17 SLOT="0"
18 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
19 IUSE=""
20
21 COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND=">=dev-python/docutils-0.10[${PYTHON_USEDEP}]
23         ${COMMON_DEPEND}"
24 DEPEND="${COMMON_DEPEND}"
25
26 S=${WORKDIR}/${MY_P}