*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / docker-pycreds / docker-pycreds-0.4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python bindings for the docker credentials store API"
10 HOMEPAGE="https://github.com/shin-/dockerpy-creds/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND=">=dev-python/six-1.4.0[${PYTHON_USEDEP}]"