media-fonts/font-misc-misc: dropped ~x86-interix
[gentoo.git] / dev-python / dnspython / dnspython-1.12.0-r200.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="DNS toolkit for Python"
12 HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
13 SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
14
15 LICENSE="ISC"
16 SLOT="py2"
17 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
18 IUSE="examples test"
19
20 RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
21         !dev-python/dnspython:0"
22 DEPEND="${RDEPEND}
23         !dev-python/dnspython:0
24         app-arch/unzip"
25
26 # For testsuite
27 DISTUTILS_IN_SOURCE_BUILD=1
28
29 python_test() {
30         cd tests || die
31         "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
32         einfo "Testsuite passed under ${EPYTHON}"
33 }
34
35 python_install_all() {
36         use examples && local EXAMPLES=( examples/. )
37         distutils-r1_python_install_all
38 }