dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / djangocms-text-ckeditor / djangocms-text-ckeditor-3.5.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Text Plugin for django CMS with CKEditor support"
11 HOMEPAGE="https://pypi.python.org/pypi/djangocms-text-ckeditor/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 KEYWORDS="~amd64 ~x86"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="
21         ${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23 "
24 PDEPEND=">=dev-python/django-cms-3.2.0[${PYTHON_USEDEP}]"
25
26 src_prepare() {
27         sed -i 's/find_packages()/find_packages(exclude=["tests"])/g' "${S}/setup.py"
28         eapply_user
29 }