Add ~amd64 keyword to django-tables2, and update to git-2 and EAPI 4.
[wtk-overlay.git] / dev-python / django-tables2 / django-tables2-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit eutils distutils
11
12 if [[ ${PV} == "9999" ]] ; then
13         inherit git-2
14         EGIT_REPO_URI="git://github.com/bradleyayers/${PN}.git"
15         SRC_URI=""
16 else
17         SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
18 fi
19
20 DESCRIPTION="Table framework for Django"
21 HOMEPAGE="http://${PN}.readthedocs.org/en/latest/"
22 LICENSE="BSD-2"
23 SLOT="0"
24 KEYWORDS="~x86 ~amd64"
25 IUSE="test"
26
27 DEPEND="dev-python/django"
28 RDEPEND="dev-python/setuptools
29         ${DEPEND}"
30
31 src_unpack() {
32         if [[ ${PV} == "9999" ]] ; then
33                 git-2_src_unpack
34         else
35                 unpack ${A}
36         fi
37         cd "${S}"
38 }