dev-python/diff-cover: Remove Py2
[gentoo.git] / dev-python / diff-cover / diff-cover-1.0.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Automatically find diff lines that need test coverage"
11 HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
12 SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
22         dev-python/jinja2_pluralize[${PYTHON_USEDEP}]
23         dev-python/pygments[${PYTHON_USEDEP}]
24         dev-python/six[${PYTHON_USEDEP}]"
25 DEPEND="${RDEPEND}
26         test? (
27                 dev-python/coverage[${PYTHON_USEDEP}]
28                 dev-python/flake8[${PYTHON_USEDEP}]
29                 dev-python/mock[${PYTHON_USEDEP}]
30                 dev-python/nose[${PYTHON_USEDEP}]
31                 <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
32                 dev-python/pyflakes[${PYTHON_USEDEP}]
33         )"
34
35 python_test() {
36         esetup.py test || die "tests failed with ${EPYTHON}"
37 }