*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / deprecated / deprecated-1.2.6.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python @deprecated decorator to deprecate old API"
10 HOMEPAGE="https://github.com/tantale/deprecated"
11 SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
20 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         test? (
22                 ${RDEPEND}
23                 dev-python/pytest[${PYTHON_USEDEP}]
24         )"
25
26 python_test() {
27         pytest -vv || die "Tests fail with ${EPYTHON}"
28 }