Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / dev-python / datashape / datashape-0.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Language defining a data description protocol"
12 HOMEPAGE="https://github.com/ContinuumIO/datashape"
13 SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
18 IUSE="doc test"
19
20 RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
21                 dev-python/multipledispatch[${PYTHON_USEDEP}]
22                 dev-python/python-dateutil[${PYTHON_USEDEP}]"
23 DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
24         test? ( ${RDEPEND}
25                 dev-python/pytest[${PYTHON_USEDEP}] )"
26
27 python_prepare_all() {
28         # Prevent un-needed d'loading
29         sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
30
31         distutils-r1_python_prepare_all
32 }
33
34 python_compile_all() {
35         use doc && emake -C docs html
36 }
37
38 python_test() {
39         py.test || die "Tests failed under ${EPYTHON}"
40 }
41
42 python_install_all() {
43         use doc && local HTML_DOCS=( docs/build/html/. )
44         distutils-r1_python_install_all
45 }