dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / dap / dap-2.2.6.7-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Data Access Protocol client and server"
11 HOMEPAGE="http://pydap.org https://pypi.org/project/dap/ https://pypi.org/project/Pydap/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
17 IUSE="server"
18
19 RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
20         server? (
21                 dev-python/cheetah[${PYTHON_USEDEP}]
22                 dev-python/paste[${PYTHON_USEDEP}]
23                 dev-python/pastedeploy[${PYTHON_USEDEP}]
24                 dev-python/pastescript[${PYTHON_USEDEP}]
25         )"
26 DEPEND="${RDEPEND}
27         dev-python/setuptools[${PYTHON_USEDEP}]"
28
29 DOCS=( docs/bugs docs/Changelog docs/history README TODO )
30
31 src_prepare() {
32         sed -e "s/'dap.plugins'/'dap', 'dap.plugins'/" -i setup.py || die "sed failed"
33         distutils-r1_src_prepare
34 }