dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / cycler / cycler-0.10.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 MY_PN="Cycler"
11
12 DESCRIPTION="Composable style cycles"
13 HOMEPAGE="
14         https://matplotlib.org/cycler/
15         https://pypi.org/project/Cycler/
16         https://github.com/matplotlib/cycler"
17 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
18
19 SLOT="0"
20 LICENSE="BSD"
21 KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
22 IUSE="test"
23
24 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
25 DEPEND="${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         test? ( dev-python/nose[${PYTHON_USEDEP}] )
28 "
29
30 # Not shipped
31 # https://github.com/matplotlib/cycler/issues/21
32 RESTRICT=test
33
34 python_test() {
35         nosetests --verbosity=3 || die
36 }