*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cssselect / cssselect-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
11 HOMEPAGE="https://cssselect.readthedocs.io/en/latest/
12         https://pypi.org/project/cssselect/
13         https://github.com/scrapy/cssselect"
14 SRC_URI="https://github.com/scrapy/cssselect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 DEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
25
26 distutils_enable_sphinx docs
27 distutils_enable_tests unittest