8976673fc4fdcfac471dfac62f503533a2205aaf
[gentoo.git] / dev-python / cov-core / cov-core-1.15.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
7 inherit distutils-r1
8
9 DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
10 HOMEPAGE="https://bitbucket.org/memedough/cov-core/overview"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
16 IUSE=""
17
18 RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"