dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / contextlib2 / contextlib2-0.6.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Backports and enhancements for the contextlib module"
11 HOMEPAGE="https://pypi.org/project/contextlib2/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="PSF-2.4"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
17 IUSE="test"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( $(python_gen_cond_dep '
22                         dev-python/unittest2[${PYTHON_USEDEP}]
23                         ' python{2_7,3_{5,3,6,7}} pypy{,3}
24                 )
25         )
26 "
27
28 RESTRICT="!test? ( test )"
29
30 python_prepare_all() {
31         sed -i -e 's:unittest.main():unittest.main(verbosity=2):' \
32                 test_contextlib2.py || die
33
34         distutils-r1_python_prepare_all
35 }
36
37 python_test() {
38         "${PYTHON}" test_contextlib2.py || die "Tests fail for ${EPYTHON}"
39 }