1c7e2b98e61a2f98a00efb555e835a9f6c90c064
[gentoo.git] / dev-python / configshell-fb / configshell-fb-1.1.24.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A Python library for building configuration shells"
11 HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
20         dev-python/six[${PYTHON_USEDEP}]
21         dev-python/urwid[${PYTHON_USEDEP}]
22         !dev-python/configshell"