dev-python/configparser: keyworded 3.5.0-r1 for sparc, bug #606554 (thanks to Rolf...
[gentoo.git] / dev-python / configparser / configparser-3.5.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 pypy )
6 inherit distutils-r1
7
8 DESCRIPTION="Backport of Python-3 built-in configparser"
9 HOMEPAGE="https://pypi.python.org/pypi/configparser/"
10 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
15 IUSE=""
16
17 RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 python_install_all() {
21         distutils-r1_python_install_all
22
23         find "${D}" -name '*.pth' -delete || die
24 }