dev-python/click-default-group: keyworded 1.2.2 for ia64, bug #700918
[gentoo.git] / dev-python / cmd2 / cmd2-0.10.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit distutils-r1 virtualx
8
9 DESCRIPTION="Extra features for standard library's cmd module"
10 HOMEPAGE="https://github.com/python-cmd2/cmd2"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 arm arm64 hppa ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
16
17 RDEPEND="
18         dev-python/attrs[${PYTHON_USEDEP}]
19         >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
20         >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]
22         dev-python/wcwidth[${PYTHON_USEDEP}]
23 "
24 BDEPEND="
25         dev-python/setuptools_scm[${PYTHON_USEDEP}]
26         test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )
27 "
28
29 distutils_enable_tests pytest
30
31 src_prepare() {
32         sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
33         distutils-r1_src_prepare
34 }
35
36 src_test() {
37         # tests rely on very specific text wrapping...
38         local -x COLUMNS=80
39         virtx distutils-r1_src_test
40 }