dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / cherrypy / cherrypy-13.1.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 MY_P="CherryPy-${PV}"
11
12 DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
13 HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
14 SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
23         >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
24         >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
25 DEPEND="${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         dev-python/setuptools_scm[${PYTHON_USEDEP}]
28         test? (
29                 dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
30                 dev-python/path-py[${PYTHON_USEDEP}]
31                 dev-python/pytest[${PYTHON_USEDEP}]
32                 dev-python/pytest-cov[${PYTHON_USEDEP}]
33         )"
34 S="${WORKDIR}/${MY_P}"
35
36 python_prepare_all() {
37         # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
38         sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
39                 -i cherrypy/test/test_static.py || die
40         distutils-r1_python_prepare_all
41 }
42
43 python_test() {
44         py.test -v || die "tests failed under ${EPTYHON}"
45 }