dev-python/cbor2: New pkg, new dep of dev-python/autobahn-20.4.3
[gentoo.git] / dev-python / cbor2 / cbor2-5.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
10 HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
19
20 DEPENDS="
21         dev-python/setuptools_scm[${PYTHON_USEDEP}]
22         test? (
23                 dev-python/pytest[${PYTHON_USEDEP}]
24                 dev-python/pytest-cov[${PYTHON_USEDEP}]
25         )
26 "
27
28 RDEPEND="${DEPEND}"
29
30 distutils_enable_tests pytest