net-nntp/sabnzbd: bump 2.3.1
[gentoo.git] / dev-python / catkin_pkg / catkin_pkg-0.3.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
6
7 SCM=""
8 if [ "${PV#9999}" != "${PV}" ] ; then
9         SCM="git-r3"
10         EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
11 fi
12
13 inherit ${SCM} distutils-r1
14
15 DESCRIPTION="Standalone Python library for the catkin package system"
16 HOMEPAGE="http://wiki.ros.org/catkin_pkg"
17 if [ "${PV#9999}" != "${PV}" ] ; then
18         SRC_URI=""
19         KEYWORDS=""
20 else
21         SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
22         KEYWORDS="~amd64 ~arm"
23 fi
24
25 LICENSE="BSD"
26 SLOT="0"
27 IUSE="test"
28
29 RDEPEND="
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         dev-python/docutils[${PYTHON_USEDEP}]
32         dev-python/python-dateutil[${PYTHON_USEDEP}]
33 "
34 DEPEND="${RDEPEND}
35         test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
36 "
37 PATCHES=(
38         "${FILESDIR}/catkin_prefix.patch"
39         "${FILESDIR}/argparse.patch"
40         "${FILESDIR}/ros_packages.patch"
41         "${FILESDIR}/infinite_loop2.patch"
42 )
43
44 python_test() {
45         nosetests -s --tests test || die
46 }