dev-python/Babel: Stable for ALLARCHES
[gentoo.git] / dev-python / bytecodeassembler / bytecodeassembler-0.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 pypy )
7
8 inherit distutils-r1
9
10 MY_PN="BytecodeAssembler"
11
12 DESCRIPTION="Generate Python code objects by "assembling" bytecode"
13 HOMEPAGE="https://pypi.python.org/pypi//BytecodeAssembler"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip -> ${P}.zip"
15
16 KEYWORDS="amd64 x86"
17 IUSE=""
18 LICENSE="Apache-2.0"
19 SLOT="0"
20
21 RDEPEND=""
22 DEPEND="app-arch/unzip
23         >=dev-python/symboltype-1.0[${PYTHON_USEDEP}]
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 S="${WORKDIR}"/${MY_PN}-${PV}
27
28 python_test() {
29         "${PYTHON}" test_assembler.py && einfo "Tests passed under ${EPYTHON}" \
30                 || die "Tests failed under ${EPYTHON}"
31 }