*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / boto3 / boto3-1.10.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
6
7 inherit distutils-r1 vcs-snapshot
8
9 DESCRIPTION="The AWS SDK for Python"
10 HOMEPAGE="https://github.com/boto/boto3"
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 IUSE="doc test"
14 RESTRICT="!test? ( test )"
15
16 if [[ "${PV}" == "9999" ]]; then
17         EGIT_REPO_URI="https://github.com/boto/boto3"
18         inherit git-r3
19 else
20         SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
21         KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
22 fi
23
24 RDEPEND="
25         >=dev-python/botocore-1.12.4[${PYTHON_USEDEP}]
26         dev-python/jmespath[${PYTHON_USEDEP}]
27         dev-python/s3transfer[${PYTHON_USEDEP}]
28 "
29 DEPEND="
30         dev-python/setuptools[${PYTHON_USEDEP}]
31         doc? (
32                 dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
33                 dev-python/sphinx[${PYTHON_USEDEP}]
34         )
35         test? (
36                 ${RDEPEND}
37                 dev-python/mock[${PYTHON_USEDEP}]
38                 dev-python/nose[${PYTHON_USEDEP}]
39         )
40 "
41
42 python_compile_all() {
43         use doc && emake -C docs html
44 }
45
46 python_test() {
47         nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
48 }
49
50 python_install_all() {
51         use doc && local HTML_DOCS=( docs/build/html/. )
52
53         distutils-r1_python_install_all
54 }