*/*: Remove python3_4 PYTHON_COMPAT correctly
[gentoo.git] / dev-python / blinker / blinker-1.4-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
11 HOMEPAGE="https://pythonhosted.org/blinker/ https://pypi.org/project/blinker/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="doc test"
18
19 DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
20
21 python_test() {
22         nosetests -v || die "Testing failed with ${EPYTHON}"
23 }
24
25 python_install_all() {
26         use doc && HTML_DOCS=( docs/html/. )
27         distutils-r1_python_install_all
28 }