dev-python/bleach: mark s390 stable
[gentoo.git] / dev-python / bleach / bleach-3.0.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
10 HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
16 IUSE="test"
17
18 RDEPEND="
19         dev-python/six[${PYTHON_USEDEP}]
20         dev-python/webencodings[${PYTHON_USEDEP}]"
21 BDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
24
25 python_test() {
26         pytest -v || die "tests failed under ${EPYTHON}"
27 }