update pypi HOMEPAGE to avoid redirection
[gentoo.git] / dev-python / autopep8 / autopep8-1.3.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
12 HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19
20 RDEPEND="
21         >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
22         >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
23 DEPEND="
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? (
26                 ${RDEPEND}
27                 >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
28         )"
29
30 python_prepare_all() {
31         # Prevent UnicodeDecodeError with LANG=C
32         sed -e "/é/d" -i MANIFEST.in || die
33         distutils-r1_python_prepare_all
34 }
35
36 python_test() {
37         esetup.py test
38 }