dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / audioread / audioread-1.0.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Module for decoding audio files using whichever backend is available"
11 HOMEPAGE="https://pypi.python.org/pypi/audioread"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
21
22 PATCHES=(
23         "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
24         )
25
26 pkg_postinst() {
27                 einfo "You might need to enable additional USE flags in backends to"
28                 einfo "decode some types of audio files. Priority of backends:"
29                 einfo "   * mad"
30                 einfo "   * ffmpeg"
31 }