dev-python/attrs: stable 19.3.0 for hppa, bug #703062
[gentoo.git] / dev-python / attrs / attrs-19.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Attributes without boilerplate"
11 HOMEPAGE="
12         https://github.com/hynek/attrs
13         https://attrs.readthedocs.org/
14         https://pypi.org/project/attrs/"
15 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 IUSE="test"
21 RESTRICT="!test? ( test )"
22
23 RDEPEND="
24         dev-python/zope-interface[${PYTHON_USEDEP}]"
25
26 DEPEND="
27         ${RDEPEND}
28         dev-python/setuptools[${PYTHON_USEDEP}]
29         test? (
30                 $(python_gen_impl_dep sqlite)
31                 >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
32                 dev-python/pytest[${PYTHON_USEDEP}]
33         )"
34
35 python_test() {
36         py.test -v || die "tests failed with ${EPYTHON}"
37 }