dev-python/attrs: arm stable, bug #669630
[gentoo.git] / dev-python / attrs / attrs-18.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Attributes without boilerplate"
11 HOMEPAGE="
12         https://github.com/hynek/attrs
13         https://attrs.readthedocs.org/
14         https://pypi.org/project/attrs/"
15 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 IUSE="test"
21
22 RDEPEND="
23         dev-python/zope-interface[${PYTHON_USEDEP}]"
24
25 DEPEND="
26         ${RDEPEND}
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 $(python_gen_impl_dep sqlite)
30                 >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
31                 dev-python/pytest[${PYTHON_USEDEP}]
32         )"
33
34 python_test() {
35         py.test -v || die "tests failed with ${EPYTHON}"
36 }