dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / atomicwrites / atomicwrites-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8,9}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Atomic file writes"
10 HOMEPAGE="https://github.com/untitaker/python-atomicwrites"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16
17 BDEPEND="
18         test? (
19                 $(python_gen_cond_dep '
20                         dev-python/mock[${PYTHON_USEDEP}]
21                 ' -2)
22         )"
23
24 distutils_enable_tests pytest
25 distutils_enable_sphinx docs \
26         dev-python/sphinx_rtd_theme