dev-python/asn1crypto: stable 0.24.0 for ppc64, bug #647000
[gentoo.git] / dev-python / asn1crypto / asn1crypto-0.22.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
12 HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.python.org/pypi/asn1crypto/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="amd64 arm arm64 hppa ia64 ~mips ppc ppc64 x86 ~x64-solaris"
18 IUSE="test"
19
20 RDEPEND=""
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"