dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / arpeggio / arpeggio-1.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 MY_PN=Arpeggio
11 MY_P=${MY_PN}-${PV}
12 DESCRIPTION="Parser interpreter based on PEG grammars"
13 HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/igordejanovic/Arpeggio"
14 SRC_URI="https://github.com/igordejanovic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND=""
23 DEPEND="
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? (
26                 dev-python/pytest[${PYTHON_USEDEP}]
27                 dev-python/memory_profiler[${PYTHON_USEDEP}]
28         )
29 "
30 S=${WORKDIR}/${MY_P}
31
32 python_test() {
33         pytest -vv || die "Testing failed"
34 }