kde-misc/kdiff3: use HTTPS for links to dev.gentoo.org
[gentoo.git] / dev-python / apptools / apptools-4.3.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 virtualx
9
10 DESCRIPTION="Enthought Tool Suite: Application tools"
11 HOMEPAGE="http://code.enthought.com/projects/app_tools/ https://pypi.python.org/pypi/apptools"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="doc examples test"
18
19 RDEPEND="
20         dev-python/configobj[${PYTHON_USEDEP}]
21         dev-python/numpy[${PYTHON_USEDEP}]
22         dev-python/traitsui[${PYTHON_USEDEP}]
23         >=dev-python/traits-4[${PYTHON_USEDEP}]"
24 DEPEND="
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
27         test? (
28                 ${RDEPEND}
29                 >=dev-python/pyface-4[${PYTHON_USEDEP}]
30                 media-fonts/font-cursor-misc
31                 media-fonts/font-misc-misc
32                 sci-visualization/mayavi[${PYTHON_USEDEP}]
33                 dev-python/traits[${PYTHON_USEDEP}]
34                 dev-python/traitsui[${PYTHON_USEDEP}]
35         )"
36
37 python_compile_all() {
38         use doc && emake -C docs html
39 }
40
41 python_test() {
42         # Ignore test file that imports a long deprecated module of traits
43         VIRTUALX_COMMAND="nosetests -I test_state_pickler.py" virtualmake
44 }
45
46 python_install_all() {
47         use doc && local HTML_DOCS=( docs/build/html/. )
48         use examples && local EXAMPLES=( examples/. )
49         distutils-r1_python_install_all
50 }