dev-python/appdirs: revbump to 1.4.3-r1, add py38 and EAPI=7
[gentoo.git] / dev-python / appdirs / appdirs-1.4.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Module for determining appropriate platform-specific dirs"
11 HOMEPAGE="https://github.com/ActiveState/appdirs"
12 SRC_URI="https://github.com/ActiveState/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17
18 PATCHES=( "${FILESDIR}"/${PN}-1.4.3-distutils.patch )
19
20 python_test() {
21         "${PYTHON}" test/test_api.py -v || die "Tests fail with ${EPYTHON}"
22 }
23
24 [[ ${PV} == 1.4.3 ]] || die "Please remove pkg_preinst from the ebuild"
25 pkg_preinst() {
26         _remove_egg_info() {
27                 local pyver="$("${PYTHON}" -c 'import sys; print(sys.version[:3])')"
28                 local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
29                 if [[ -d ${egginfo} ]]; then
30                         einfo "Removing ${egginfo}"
31                         rm -r "${egginfo}" || die
32                 fi
33         }
34         python_foreach_impl _remove_egg_info
35 }