proj/gentoo: Initial commit
[gentoo.git] / dev-python / apipkg / apipkg-1.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="namespace control and lazy-import mechanism"
11 HOMEPAGE="http://pypi.python.org/pypi/apipkg"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="examples test"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
20         dev-python/hgdistver[${PYTHON_USEDEP}]
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         py.test test_apipkg.py || die "Tests fail under ${EPYTHON}"
25 }
26
27 python_install_all() {
28         use examples && local EXAMPLES=( example/. )
29         distutils-r1_python_install_all
30 }