dev-python/anyjson: [QA] Remove dead python impl
[gentoo.git] / dev-python / anyjson / anyjson-0.3.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Wraps the best available JSON implementation available in a common interface"
11 HOMEPAGE="https://bitbucket.org/runeh/anyjson"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 # please keep all supported implementations in 'test?'
21 # to make sure the package is used in the widest way
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/nose[${PYTHON_USEDEP}]
26                 dev-python/simplejson[$(python_gen_usedep 'python2*' 'pypy*')]
27         )"
28
29 python_test() {
30         cp -r -l tests "${BUILD_DIR}" || die
31         if [[ ${EPYTHON} == python3* ]]; then
32                 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
33         fi
34
35         nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
36 }